Az FKERES függvény és az INDEX HOL.VAN

Excelmarketing - Excel VBA makró blog - FKERES függvény használata, nem az első oszlopra

Az FKERES egy vízválasztó függvény. Sokan úgy tartják, ennél összetettebb képlettel már nem tudnak megbirkózni az Excelben. Pedig egyrészt tényleg nem is olyan bonyolult függvény ez, másrészt pedig, ott az INDEX HOL.VAN, amivel olyan problémát is meg lehet oldani, amire az FKERES már nem képes.

FKERES képlet használata

Az FKERES segítségével egy kritérium mentén tudunk megkeresni valamit egy táblázat első oszlopából.

Példa:

Az adott táblázatban egy ID azonosító alapján keressük, hogy mi a keresztneve az adott illetőnek.

FKERES függvény használata

A képlet így néz:

=FKERES(C11;A1:E8;3;HAMIS)

C11 – ebben a cellában van azaz azonosító, amelyikhez a hozzátartozó keresztnevet keressük
A1:E8 – ez a tábla, ahol mind a C11 értéke, mind pedig az ahhoz tartozó keresett érték is szerepel
3 – az oszlop, amiben a keresett érték, vagyis a keresztnév szerepel
HAMIS – pontos egyezést akarunk a C11-es cella értékével

De mi van akkor, ha nem az első oszlop kell nekünk? Mi van akkor, ha a fenti példából kiindulva, a vezetéknév alapján keressük a keresztnevet.

Az INDEX és a HOL.VAN függvény alkalmazása FKERES helyett

Ha az FKERES függvény nem nyújt elegendő megoldást az Exceles problémánkra, mert az első oszlopos korlát akadályoz minket, akkor az INDEX és a HOL.VAN függvények együttes ereje tud segíteni nekünk.

INDEX és a HOL.VAN képlet

A fenti példára nézve, a keresztnevet keressük a vezetéknév alapján.
A képlet így néz:

=INDEX(A1:E8;HOL.VAN(C11;B1:B8;0);3)

A1:E8 – ez a tábla, ahol mind a C11 értéke mind pedig az ahhoz tartozó keresett érték is szerepel
C11 – ebben a cellában van azaz azonosító, amelyikhez a hozzátartozó keresztnevet keressük
B1:B8 – Az oszlop, ahol a C11 cellánk értéke is megtalálható
0 – Pontos egyezés
3 – az oszlop, amiben a keresett érték, vagyis a keresztnév szerepel

Azonban ennél fontos tudni, hogy ha több helyen is szerepel a kritérium, -jelen esetben is több azonos vezetéknév is van az oszlopban – akkor az első találatot fogja megadni.

Mennyire találtad hasznosnak ezt cikket?
[Összes szavazat: 1 Átlag értékelés: 5]